Back to overview
Degraded
ChargEye UI performance degraded on chargeye.io and kempower.com domains
Apr 27, 2026 at 5:42am UTC
Affected services
ChargEye / MyKempower User Interface
Resolved
Apr 27, 2026 at 9:27am UTC
Incident was resolved with a rollback release.
Affected services
Created
Apr 27, 2026 at 5:42am UTC
Users accessing chargeye.io and mykempower.com experienced failures including inability to log in for some customers, and failure to load station or vehicle information for others.
Impact on backend services and revenue is non-existent.
Kempower apologizes for disruption. The team resolved the problem with a release rollback.
Affected services